Problem
When I attempt to update the license on our Sonatype Nexus instance, I am hit with "Invalid authentication ticket" once I click Install License-> accept terms & agreements -> sign in with password.
Common causes
1. It is possible that you are not entering the password quick enough. Try entering the password when prompted within 10 seconds of starting the license update.
2. If Nexus is running in legacy HA-C mode, the issue may cause by the Nexus UI is not sending all UI requests to the same node. This can be reviewed by merging the request.log files from all nodes. Then checking your login session and UI requests from your IP for that session to all nodes.
A requirement of HA-C is that all UI requests for the same session need to be sent to the same node.
From: https://help.sonatype.com/en/load-balancing.html#sticky-sessions
The Nexus Repository UI uses a cookie named NXSESSIONID to maintain a users state. The load balancer should be configured to enforce sticky sessions for requests containing this cookie.
User UI state is unique to each node in the cluster. All UI requests for the same session should be directed to the same node.