CVE-2019-16530 - Nexus Repository Manager 2 & 3, and Nexus IQ Server - Remote Code Execution - 2019-09-19

Date: October 15th, 2019

Affected Versions:

  • Nexus Repository Manager 2 versions up to and including 2.14.14
  • Nexus Repository Manager 3 versions up to and including 3.18.1
  • Nexus IQ Server versions up to and including 72

Fixed in Version:  

  • Nexus Repository Manager 2 version 2.14.15 and later
  • Nexus Repository Manager 3 version 3.19.0 and later
  • Nexus IQ Server version 73 and later

Summary:

A remote code execution (RCE) vulnerability has been discovered in Nexus Repository Manager 2, Nexus Repository Manager 3, and Nexus IQ Server.  

An attacker with elevated privileges can upload a specially crafted file. That file can contain commands that will be executed on the system, with the same privileges as the user running the server. We have fixed the issue by ensuring the values are properly verified. This advisory provides the pertinent information needed to properly address this vulnerability, along with the details on how to reach us if you have any further questions or concerns.

We are not aware of any active exploits taking advantage of this issue. However, we strongly encourage all users of NXRM and IQ Server to immediately take the steps outlined in this advisory.  We are highly recommending all instances of NXRM 3 be upgraded to 3.19.1 or later, all instances of NXRM 2 be upgraded to 2.14.15 or later, and all instances of IQ Server upgrade to 74 and later. The latest versions can be downloaded from:

Nexus Repository Manager 2 Download

Nexus Repository Manager 3 Download

Nexus IQ Server Download

For detailed information on upgrading, please see:

Nexus Repository Manager 2 Upgrade and Compatibility Notes 

Upgrading Nexus Repository Manager 3.1.0 and Newer

Upgrading the IQ Server

Support:

If you run into any problems, or have any questions/concerns, please contact us by filing a ticket at https://support.sonatype.com.


Frequently Asked Questions:

Q:  What is the risk associated with this vulnerability?

A:  An attacker with elevated priveledges can upload a specially crafted file.  That file can contain commands that will be run on the underlying systems as the user who owns the server process.  

Q: What preconditions must be met in order to be vulnerable?

A: An attacker must have network access to the Repository Manager instance, as well as administrative access to the Repository Manager.

Q: Are there implications associated with this advisory itself?

A: Unfortunately, disclosure means bad actors may try to take advantage.  While we have initially limited the information to the minimum details necessary for users to affect an appropriate fix, this merely slows down a would be attacker.  As such, we are advising all organizations utilizing NXRM and IQ Server to immediately assess their individual impact and take appropriate action in response.

Q:  Where can I obtain more information associated with the vulnerability?

A:  At this time, and in the interest of best protecting our user community, we are limiting the information released to that absolutely required in order to assess impact and affect remediation. Please contact support for more information.

Q:  Why is Sonatype making this information available?

A:  This is part of a responsible disclosure process.  We are taking a concerted and proactive approach in our outreach activities and an effort to achieve the most rapid remediation possible.

Have more questions? Submit a request

0 Comments

Article is closed for comments.