Problem
When clicking on a routing rule Nexus Repository 3 to edit or view its configuration, the UI reports a 404 not found error message.
Cause
This is a known bug with internal id of NEXUS-47958 affecting these products
- Nexus Repository 3.80.0 through 3.83.0
This happens when the name of the routing rule contains non-alphanumeric characters such as dash or period.
Workaround
Renaming the routing rules using the REST API to names without special characters will allow them to be edited and viewed in the UI.
Example for a rule named "my-rule-name":
- Download the existing routing rule as json file using REST API.
$ curl -o rule.json -u admin:admin123 http://localhost:8081/service/rest/v1/routing-rules/my-rule-name - Edit the output rule.json file and update the name attribute to be a name without special characters, such as "myrulename".
- Update the changes to the routing rule using REST API
$ curl -u admin:admin123 -X 'PUT' 'http://localhost:8081/service/rest/v1/routing-rules/my-rule-name' -H 'accept: application/json' -H 'Content-Type:application/json' -d @rule.json
Solution
Please monitor release notes for the fixed version of this issue and upgrade when available.